Upcoming System Requirements Change

Please be aware that there is an upcoming change to the minimum system requirements for running LabStats On-Premises. Effective January 1, 2018, the minimum system requirements for the On-Premises version of LabStats will no longer support Windows Server 2008 SP2 and will require the latest version of the Microsoft .NET Framework (4.7.1).. Depending on your current operating system, this change may not affect you. However, if it does, you can continue using your current version until you upgrade.

Please review our support document for further information.

Please share this message with anyone who manages your LabStats installation.